[DOTNET] Container cannot start on Podman 2.0.X, Failed to create CoreCLR, HRESULT: 0x80070008

Problem

The container cannot start on the error message is

Failed to create CoreCLR, HRESULT: 0x80070008

Environment

Solution

Update Podman to Lasted Version, If Podman on RedHat 8.x. My Suggestion is to update RedHat to the latest version (Current 8.9) that comes with Podman 4.6.1.

If you upgrade Podman without updating RedHat. Sometimes I found the container crashed when started or received some signal such request / Podman exec etc

I assume that Podman in RedHat has dependency with conmon and many packages with OS RedHat, After Update RedHat 8.9. You can try Podman 4.9.x

RHEL Upgrade Note

//check subscription manager 
subscription-manager register --release=8.2

//View Release
subscription-manager release
//List Current Kernel
uname -r
dnf list kernel
  • Run a System Update
sudo dnf check-update
sudo dnf upgrade -y
  • Reboot
sudo reboot
## OR ##
sudo shutdown -r now
  • Verify the RHEL update
uname -a
uname -r
cat /etc/os-release
tail -f /var/log/logfilenames
dmesg | grep -i 'err|warn|cri'
ss -tulpn

Note:

  • By Default Podman automatically update when upgrading RHEL, but on RHEL8 RHEL 8 features "Application Streams," which allows administrators to "lock" specific versions of app such as container tools which include podman. You can check your current active stream using this command
dnf module list container-tools
  • if you want to lock try using this command.
sudo dnf module enable module-name:stream
# Example
dnf module enable container-tools:3.0 

Reference